Unable to parse server response to PWD command

I tried setting up a network drive using FTP with TLS. I can connect without any problems using FileZilla, however I get this error from RaiDrive:

{"WinErrorCode":1237,"NotifyErrorCode":103,"RaiException":"Drive Auth Failed","Filename":"AUTH","InnerException":"Unable to parse server response to PWD command."}

The authentication is definitely correct - if I change username or password, another error (503) occures.

During testing, I noticed that the path seems to be kind of a problem. If I access any existing directory inside the server, it works as expected, the problem occurs only on the root (/), which I need to get access to.
I tried using a path like /any_existing_folder/.., but it just gets replaced with /.

What could be the problem and what could I try to fix it?
Thanks in advance.

Hi~ @jabele10 ,

To verify what you’re describing, we’ll need your FTP server type and server version. You’ll also need to try changing the charset to whatever is set on your FTP server.
Please tell us the two pieces of information We mentioned, try changing the character set, and let us know the results.

Thanks for the reply.

Unfortunately I don’t know anything about the running server since it is the file server of my Bambu Lab A1 Mini 3D Printer. Therefore I don’t have any access other than this FTP server and the internal connections with Bambu Studio.

The character set of utf-8 should be correct (worked on paths other than /) and I tried a few other common ones, which didn’t work either.

Is there some way, I can see the actual responses? By this I could check for differences of the responses between the root path and any path inside.

Could you try below?

  • iso-8859-1
  • us-ascii

Thanks for the help.

I actually tried every charcter set selectable - always the same problem.
That’s the result I expected since every path except the root is working with utf-8

Hi~ @jabele10 ,

If you specify a single subfolder in the path of your RaiDrive, try it and see if it works, and let us know your results.

Hi~ @jabele10 ,

We’ve sent you a patch via email.
Please check your email.

As stated earlier every existing subfolder (/folder1, /folder2 or /folder1/folder3) was working correctly.
Only the root directory (/) was not working. The only difference from the picture was that I had already created the drive and was just modifying it (therefore replacing an empty path with “/”).

Thanks a lot for your help.
The patch is working correctly, I got access to the whole network drive without any problems.
Just out of interest, what actually was the problem?

Your FTP server produces the PWD command response for RaiDrive not to parse.
The prior RaiDrive version treated it as an error but the new one does not.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.