Sometimes Fails to Save

I am on a Windows 10 PC. I access a remote NAS drive. I open a file. Make changes and Save every few minutes. I make the last changes, Save, close, and go on to other projects.

Minutes later, an error message pops-up saying the file wasn’t saved.

None of the changes were saved. Even after multiple Saves while working with the file.

This happens maybe one file in twenty.

Hi~ @Dan_Verssen,

Could you send log(C:\ProgramData\OpenBoxLab\RaiDrive\log) file to support@raidrive.com when you met this trouble?

I don’t have that file path on my C:

My 2 main folders for apps are:
Program Files
Program Files (x86)

https://www.isumsoft.com/windows-10/how-to-show-hidden-files-and-folders-in-windows-10.html

I just sent all the files in the “Log” folder.

Hi~ @Dan_Verssen,

Your log said two kinds of error messages.

  1. The remote name could not be resolved
  2. Already Locked

#1 means that an internet connection is unstable and then RaiDrive cannot connect to your Synology NAS.

#2 can happen when two applications open the same file with create-mode.
This is a typical “File Lock” operation and only the first application can have the permission to save(write).

Hi~ @Dan_Verssen,

We looked around the log files you sent by email.
The last issue still seems to happen.

Could you let us know what kind of WebDAV server is?

I think this is what you are asking for…

The strange thing is, it was working perfectly from January to February, then I started getting these errors.

The odd thing is. I can read, write, etc all as normal to the main level of the NAS. The problems only pop-up when working with folders under the main level.

Hi~ @Dan_Verssen,

Could you reconnect without “File Lock” option?
image

Your log said that at the same time two more applications were accessing a single same file with creating mode.

Hi, I try to use webDAV connection to our server but there is problem to save something to server through RaiDrive. I tried to setup different application called WebDrive and file save works fine.
There is problem with permissions in RaiDrive. All credentials are the same in both apps.
Here is message when I tried to save file via RaiDrive.
image
image

1 Like

Hi~ @Jirka_Kopecky ,

Could you send log( C:\ProgramData\OpenBoxLab\RaiDrive\log ) files to support@raidrive.com when you met this trouble?

I unchecked File Lock and reconnected. I have been able to open, save, and close many files with no issues.

File Lock is important to me. I have multiple people accessing files from different locations.

What is the next step?

We are trying to reproduce this issue for the “TXT” file type.
In this case the application has the key whether the file lock is possible.
Could you let us know what the application is to save a text file?

I am just using Windows Notepad.

txt documents seemed to work okay with File Lock on.

The documents I had problems with are: Photoshop, Word, and QuarkXpress

Collaboration(co-edit) in Microsoft Office and QuarkXpress works fine in “RaiDrive File Lock” environment while Photoshop does not.

Adobe products seem to provide their own environment for collaboration.