Remotre server returned error (404) Not Found

Raidrive has worked fine for months, connecting to Synology NAS, but now will not connect, giving reason: The remote server returned an error :(404) Not Found
I have tried stopping firewall and virus checker, but it refuses to connect. Any help much appreciated.

1 Like

Hi~ @John_Colles ,

We need three pieces of information to confirm the issue you are talking about.

  1. Log file(C:\ProgramData\OpenBoxLab\RaiDrive\log)
  2. Results after testing to see if the same issue occurs in Windows built-in WebDAV
  3. Check the WebDAV connection path on Synology Admin page

Please send us three kinds of information by e-mail(support@raidrive.com) and we will tell you again after confirmation.

I am having a similar issue, I can’t connect to a specific share on Synology.

Just in case it helps, I had this same error. I found out that I had accidentally placed an index.html in the main WebDAV share, so RaiDrive started producing a 405 error since the file doesn’t process as a WebDAV file listing.

I deleted the index.html file and started getting 404 errors. Restarting the WebDAV server, RaiDrive, and even my computer didn’t fix the problem.

This is a rudimentary fix, but I think RaiDrive had cached the index file so when it doesn’t exist it’s getting confused. So I deleted the entire cache in ‘C:\ProgramData\OpenBoxLab\RaiDrive\Cache’, and that fixed the connection for me. My cache was tiny, so I believe there was nothing left to process. But be careful as you may want to be sure you don’t delete cache files RaiDrive is still processing for upload.

I’m unsure if it is the same cause of the problem as you, but I thought I’d mention it.