OneDrive Business - Aborted Delegation

Sorry for my bad English. I’m using a translator, but I hope I can make myself understood.

I have tried to connect to OneDrive Business but when I log in in the browser the message “Delegation aborted” appears in RaiDrive (Reason: The requested function is not allowed).

Please can you help me solve this.

Hi~ @Aldo_Jacobo,

Could you send log files to support@raidrive.com?

  • C:\ProgramData\OpenBoxLab\RaiDrive\log

Ok, I’ll send them to you right now.

Can you sign into OneDrive Business from a web browser with the same account?

Yeah.
I have changed browsers and I can log in without a problem.

In fact, in the browser it appears that the account has been accepted, but in Raidrive I get the notice.

If you are using Microsoft 365, you need to ask your administrator.

One detail I forgot to mention.

Everything worked excellent. This error started after the failure that occurred a few days ago with OneDrive (Raidrive 504 Gateway Time-out “Raidrive 504 Gateway Time-out”).

Since then I have had this problem.

Could you remove that drive from RaiDrive and then add a new one?

Do you mean installing Raidrive again?

No, just about a drive.
https://docs.raidrive.com/storages/OneDriveBusiness/#drive-remove

I can’t delete it, because the drive is not created in Raidrive, only that warning appears.

If so, we recommend refering to OneDrive Business - Aborted Delegation - #6 by RaiDrive

I reviewed “Configure how users consent to applications - Microsoft Entra ID”. And everything is fine.

What seems strange to me is that I have tried to add other OneDrive Business accounts and it is not possible. I have also tried with personal accounts but I get the same error.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.