MEGA Folders Not Showing (Specially ones with Links)

So I am new to RaiDrive, currently on free trial but hoping I can solve the issues to continue using the service. My goal is to see my Mega cloud as a Local Drive. When I connect to Mega, it does create a Local Drive, that for whatever reason it is called 'Disconnected Network Drive" and I see some folders inside but the vast majority of my folders don’t show up or are missing.

I have over 300 folders on my Mega and only 13 are showing on the created local drive. Important thing I noticed, all of the ones showing are Folders that have no links created for them. All folders not showing have a Link created for them via “GET LINK” so it can be accessed via a link by others.

If I create a new folder on MEGA, it then shows on the Local Drive, if I then create a link for this newly created folder after it is showing on my local it will keep showing and will show content I add to it.

However, folders that had links created for them prior to RaiDrive connecting do not show at all, even if I right click them, REMOVE LINK, so there is no long a link to access them.

I have tried removing existing links of various folders, uninstalling RAIDRIVE with Revo, reinstalling it and resyncing and they still do not show.

As an note that might matter or not, I do not have MegaSYNC installed. Just RaiDrive

Hi~ @carioksteam ,

MEGA recently changed its routines regarding encryption, and this has caused shared folders to become invisible in RaiDrive.
Once a share was sent or received, the folder was no longer visible because a new encryption key was applied.
We’re working on a fix for this issue, which will probably take 2-3 weeks.
We’ll let you know when it’s finalized.

Hi~ @carioksteam ,

We’ve created a new patch that fixes the issue you’re describing, please install it and test it out and let us know your results.
If the issue persists, please send us a log file.

Hi~ @carioksteam ,

We’re sending you a slightly improved version of Mega’s new API-related features.
Please download it from the link below and give it a try.
And be sure to let us know how it goes.

Best regards,
RaiDrive Support

Hi~ @carioksteam ,

Have you tried installing the new version we sent you?
We’d be grateful if you could let us know if that resolved the issue.

So, I have been holding back on installing an update as made worked around it by creating new folders (not shared) → copying the contents of the previously shared folders into these and sharing them again only after I had synced RAI DRIVE locally… That way they keep on working after I eventually share them.

However, today I installed the version you sent above on a new machine and it doesn’t connect to Mega at all… it is just hanging for over 10 min and nothing, drive doesn’t show:

Additionally, if I install the publicly available stable version the old issue is still there… Shared folder don’t show / or show empty

Actually, I just looked back at it and it seems to have finally synced after 20 min. And good news! It is working. Great job! Thanks for fixing it