RaiDrive will not mount any account

Anytime I add a account to Raidrive I get an error code 214. This happens no matter what type of file is trying to be added. I have updated, uninstalled and reinstalled Raidrive.

Has anyone seen this and have a possible fix?

Hi~ @mykingbiz ,

Try updating Windows and if the issue persists after the update, please e-mail(support@raidrive.com) the log file(C:\ProgramData\OpenBoxLab\RaiDrive\log). We will tell you again after checking.

Hi~ @mykingbiz ,

This may be due to the missing or incorrect Cipher Suites.
Download IISCrypto.exe and configure Cipher Suites.
Check most of them and connect them. If you still can’t connect, press the Best Practices button to set it up automatically, try connecting, and let us know the result.

Downloaded the IISCrypto.exe tried the standard and rebooted. I received the same error when trying to connect my account.

I then used the best practices button and rebooted and received the same error.

Hi~ @mykingbiz ,

Check all Ciphers in IISCrypto.exe and try again after rebooting.
If the problem persists, it seems that you need to find the cause using a tool such as WireShark.