Can't use MEGA


today I tried to use RaiDrive with MEGA. But it only loads and doesn’t let me change a single thing.

Even tho I just upgraded to pro inlcuding MEGA as addon. But I have the same issue with logging in. It just loads and loads.

Is that a known issue?

Update: It took about an hour, but now its mounted. So the problem is solved.

Since latest updates, it takes way longer to connect to MEGA. About the same time it takes the MEGASync windows app to make a full re-scan. But at least now : it works :wink:
With earlier versions, connecting to MEGA was fast but the result was, after each computer restart : an empty MEGA local drive.

Hi~ @NothingTV, @Hansolocambo

Can you send us a log of the issue that occurred via e-mail( to analyze the issue of slow MEGA connection?

It’s not really slow. Just the connection/mapping. Besides of that it doesn’t update/read new files. I just uploaeded several things (via MEGAsync) and restarted the MEGA connection, RaiDrive even the server. But it still doesn’t show the newest files. I’m not sure that its really a RaiDrive or MEGA thing, mh.

1 Like

I installed Raidrive about two months ago and connecting to MEGA was hours of struggling per day. Because most of the time : it would connect and display an empty drive. Only a “Reload your account” from and/or a “Force a Full Scan” from the MEGASync app and then a restart of Raidrive would, most but not all the time, fix that issue.

Just for info : I used often the “Check Update” in Raidrive app’s interface and, by the way, the interface always told me that I was up to date. It’s only when I came to this website about a week ago that I realized there had been a few new versions that Raidrive app never told me about.

Anyway : Seeing there had been updates, II installed the most recent version a week ago (running 2020.11.30 now). And things changed a lot in the right direction. What an amazement to see Raidrive connected to MEGA with a really updated MEGA content visible in Windows Explorer. This, Raidrive connecting properly when Windows starts, never happened once before this update. So that’s great.

BUT, as stated by @NothingTV there is now a big issue that I never noticed before : Raidrive does not ever updates the MEGA content visible locally in (at least ?) one situation.

To explain that, let’s call C: the local hard drive(s), let’s call Z: the mounted MEGA cloud storage.
What works fine :
1- I use Windows Explorer (WinEx) and I transfer a file from C: to Z:
Content is updated properly (meaning : on the mounted drive Z: and on the synched folders in C:)
2-I use WinEx to copy/move content from Z: to C:
Content is updated properly.
3- I use WinEx to copy/move content from Z: to another folder in Z:
Content is updated properly
4- I use to copy/move content from a MEGA folder to another MEGA folder
Content is updated properly.
5- I use WinEx to drag&drop a file from C: onto
Content is updated properly.
6- I use WinEx to move a file from one C: folder (synched to MEGA) to another C: folder (Synched to MEGA)
Content is updated properly (and the file doesn’t need to be uploaded again, MEGASync and Raidrive both understand the local movement and the same happens in the cloud, which is great).

All this sounds great until… :
6- I use WinEx to move a file from C: to a synched MEGA folder on C:
MEGASync uploads this file to its corresponding synched cloud folder. But locally :
Content is not updated (invisible on Z:). Raidrive does not see anything and waiting 24 hours (I tested) doesn’t change that fact.
Now, what about this particular file using : I see it where MEGASync synched it, in the shared folder. All good. But now comes the weird part : if I move that specific file that Raidrive doesn’t see, using web interface : the file appear to be moved for a second, then suddenly reappears. So it is in 1 place, I can’t move it using and Raidrive can’t see it.
I run a “Reload your account” from the web interface. Try to move the file again : still can’t move it. wow.
I run a “Force Full Scan” from MEGASync. Takes a lot of time. Now I try again to move the file. And it works !
That’s fucked up…

I still don’t know which one is the culprit : and its “Reload your account”, or MEGASync app and its “Force a full Scan”. But it definitely seems to come from there more than from Raidrive… I don’t know how Raidrive gets its information of our storage content, but it definitely seems to be from or more probably from MEGASync. And when they fuck up, Raidrive fucks up too…

There should be, in my opinion, an option in Raidrive to run a full scan of the cloud storage the way MEGA Sync does (if that’s even possible ?). Scanning an 8TB cloud drive with about 20.000 folders and 420.000 files takes time. But at least when it’s done : all should be good :wink:

Anyway, It’s not perfect yet. But we’re getting there :wink: Problem I think is that MEGASync client isn’t perfect. This “Force Full Scan” proves that they know something’s wrong with their synch solution.
My Raidrive + Mega experience is way more convincing and pleasant now than it was 2 months ago.
I trust your coding competence to find solutions as MEGA seems way more tricky to map properly than GDrive or Dropbox.
Cheers. And happy New Year to the Team.

Hi~ @Hansolocambo, @NothingTV.

After creating the drive, enter the drive option, check “Update storage changes asynchronously”, connect and try. If the problem persists, please send a log file(C:\ProgramData\OpenBoxLab\RaiDrive\log) via email( and download Night Build to check it?

1 Like

All right. Was wondering about this particular option. Cool.

If this option is what makes the difference, maybe should it, by default after installation of Raidrive, be ON. “slow” (as written on the interface) or not, if it’s what makes it work, then ON it should be.

Cheers. I’ll try that and keep you informed.

I come back here after having used Raidrive’s latest version and especially after having ticked “Update storage changes asynchronously”.
And : wow. Such a game changer. Everything works perfectly. Not 1 issue in 5 days (since my last post). I did tons of thorough tests and it seems to be just perfect now. This option really needs to be ON by default when first mounting (at least) a MEGA account.
Just perfect. d(-_^)