Can't connect to MEGA for about a week

I tried to uninstall Raidrive with Revo as this worked twice (some kind of reset equivalent to a clean reinstall would be nice). But I just can’t connect anymore. Raidrive runs all day long using about 9% of all my CPU cores and a minimum of 1GB of RAM (I can clearly hear the computer slow down when I finally abandon and stop Raidrive which sucks electric power for hours for nothing…). It connected only once yesterday I think. But I can’t let the program run for hours and hours waiting, without knowing if it’s gonna work before I go back to sleep.
I attach logs here. Hope this’ll help (maybe let us upload 7z, rar, etc. ?)
center.log (293 Bytes) center.log.2 (172 Bytes) center.log.3 (400 Bytes) service.log (2.1 KB) service.log.1 (116.6 KB) service.log.2 (28.2 KB) service.log.3 (5.1 KB)

Hi~ @Hansolocambo,

Would you like to check it out in the new Night build, version 2020.11.39? Check it out and let us know the result. If the issue persists, please tell us again.

Since I began to use Raidrive (3 months ago), from within the User Interface I always read : Update > Check > You are using the latest version, no matter how far behind I may be in the updates.

Umpteenth manual uninstall / install then.

11.39 installed. (11.38 removed as clean as possible with Revo)
Raidrive now “connects” blazing fast : to nothing. Raidrive shows “Unknown Space”.
File manager shows an empty drive. It’s not working at all anymore.

P.S : Just for info, Download button on the main website’s page takes us to version 11.38, the one I have installed. Nightly build 11.39 seems only available for those who read the forum’s announcement.

Could you send log files of version 2020.11.29 to

2020.11.39 you mean ?
Log files :
center.log (293 Bytes) center.log.1 (586 Bytes) center.log.2 (172 Bytes) service.log (1.1 KB) service.log.1 (10.8 KB) service.log.2 (1.6 KB) service.log.3 (1.4 KB)

Also sent to

Hi~ @Hansolocambo,

Sorry for the inconvenience.
Mega should always fetch the entire file list after logging in. If you have a lot of files, this can take a very long time. So, when we fetch a list, we process the DB and reuse it. However, sometimes this list request fails.
Most of the failures are when Mega server responds with RETRY. This error occurs when there are too many requests from the server. (Error Msg : Request failed, retry with exponential back-off)
After this failure, there was a problem that no list was displayed as the situation in which there was no list storage DB. Also, the capacity information is not displayed properly due to the same error.
If we fail to get the list of files, the connection will fail, and we have modified so that an error message is immediately displayed to the user.
The fixes will be reflected in the next Night Build.

Hi~ @Hansolocambo,

We have sent you a new patch by email. We would appreciate it if you can tell us the result after checking if the issue is resolved.

Thank you very much for sharing this explanation of what causes the issue, good also to know that there might be a way to solve the issue since you seem to know what causes it.
I have an 8TB MEGA storage (7.38TB real size) with 1,136,786 files and 98742 folders. So sure scanning all that takes time.

I installed the v.11.39 a few days ago. And for the moment it’s been working really fine. But I’m gonna try the one sent by mail, thanks for that, and see how it behaves.
Thanks for those efforts at making the connection to MEGA always better.

Hello. After new patch (2020.11.43) I cannot login into my MEGA account:

Worked perfectly with 2020.11.39. Where can I download .39?

Hi~ @MEGAuser,

In version 11.43, if the file list cannot be fetched when connecting, it is fixed to handle an error immediately.
Mega should always fetch a full list of files when connecting, and sometimes fail for a number of reasons.
If the connection fails, please try again after a while.
If the error persists, please email( the log file(C:\ProgramData\OpenBoxLab\RaiDrive\log).

Issue is persistent. No matter how long I wait. I sent you the log via eMail. I guess this line will be crucial:

2021-03-09 12:47:40.393 [ERROR] Mega API : MEGA : Response Exception : 0/4 : {"WinErrorCode":1237,"NotifyErrorCode":214,"RaiException":"HttpPostJson Fail","InnerException":"Unexpected character encountered while parsing value: \u001f. Path '', line 0, position 0."}

Bro just use .39. Everything works like a charm with that version.

Yeah. I have no issues for a while you’re right. Newer versions fixed a lot of issues.
MEGAS connects instantly. I don’t seem to get any issue where I know a file is there but I can’t see it. Raidrive works now really well with MEGA so far. That’s a relief :wink: